1. Having trouble logging in? Try closing your browser and re-opening it. If that doesn't work, try a different browser or device. The site will be updated soon to resolve these browser issues.
    Dismiss Notice
  2. Dismiss Notice
  3. Want an XS400.com t-shirt? Go to the store to order. Limited sizes and quantities available.
    Dismiss Notice

81 XS400 RH Handlebar Switch...Brown??

Discussion in 'The Garage' started by Italianzero, May 26, 2019.

  1. Italianzero

    Italianzero XS400 Member

    Greetings all,

    Ordered the RH Handlebar switch with a part that said it was compatible but in my OEM housing both Killswitch wires are R/W.

    OEM.Internal.jpeg

    On the replacement the (internal) right-side Killswitch wire is brown. Everything else is the same inside.
    New.Internal.jpeg
    The Replacement Female plug (white) is also different than OE (black).
    New.Female.jpeg
    OEM.Female.jpeg
    (OEM uses bullet connectors and the Replacement uses slot connectors, too)

    Can I just splice the brown wire form the Replacement to the correct (which one...) R/W wire and use the OEM Female End from the original switch????

    Thank you!
     
  2. jed74126

    jed74126 XS400 Member

    By the looks of it I don't think it matters as long as you keep the brown and red wires from the new switch matched with the red with white stripe wires from the old switch. It's a simple on and off switch. Be safe and check continuity from the switch terminals to the switch casing (ground)with the switch in each position. If there is no continuity from each terminal on the switch to ground then it shouldn't make a difference which red with white you connect to the brown.
     
  3. Italianzero

    Italianzero XS400 Member

    Checked everything, spliced together, installed the new control and as soon as I reconnected the battery it was dead. Only throwing ~3V. Charged all night, only came up to ~9.

    I thought the battery was brand new when I picked up the bike a couple months ago. If I have to get a new one, should I just get a new reg & rec as well? Or just get a new (preferably sealed) battery?

    Strikes me as odd the battery would drain will it’s disconnected, but it has been sitting for about 2 weeks while I was moving.
     
  4. jed74126

    jed74126 XS400 Member

    Depends on the state of charge the battery had before sitting that long. I know if you let a battery sit for a while below 10 volts it's not good for the battery. I would try a new battery first before buying other components especially if they were good before. Maybe test those if your not sure if they were good before. Dont quote me but Walmart sells Everstart batteries and may have one on the shelf that fits. They may not be the best batteries but I have had good luck with them as long as they stay charged at or above 12 volts. Had them in my ATV for over 4 years and never took it out in the winter. Sat in cold storage (temps. below freezing) and never had a problem starting it in the spring. Lucky I guess.
     
  5. Regarding your RH switch. I bought a new switch and had the same problem. I removed the wiring harness from the old one, cleaned it up and transplanted it into the new switch housing. Saved me from splicing and having the thing look bad. Take lots of pictures as a reference when doing this.
     
  6. XSLeo

    XSLeo XS400 Junkie

    I assume your PO told you the battery was new. Most say anything to seal the deal.
    I usually consider batteries to be worthless on bikes I get unless the seller shows me the receipt from when they bought it.
    I have had good luck with AGM batteries from Ebay. I spend around $60-$70 for one. That's shipped. Just fully charge before use.
    Leo
     

Share This Page