1. Having trouble logging in? Try closing your browser and re-opening it. If that doesn't work, try a different browser or device. The site will be updated soon to resolve these browser issues.
    Dismiss Notice
  2. Dismiss Notice
  3. Want an XS400.com t-shirt? Go to the store to order. Limited sizes and quantities available.
    Dismiss Notice

Charging Issue - R/R tested, Stator and field coil tested

Discussion in 'The Garage' started by cezzz, Apr 18, 2023.

  1. cezzz

    cezzz XS400 Member

    I have a 79 XS400, main issue is I run the bike with a full charged battery and drains after a 20-30 min ride and bike shuts down and cant restart. I determined the battery is not charging due to when I rev up the bike there is no jump in ohms coming form the stator.

    I got a Rick R/R for Lithium Ion going to a lithium-ion, and tested it and all good on that side.
    Battery was reading at 13.7 V.
    Pretest touch the 3 leads coming the stator .7 ohms reading. The stator checks out at 1.2 ohms 1.2 -.5 = .7
    I turn on the bike revved up 2,500, the voltage did no go up.
    I revved up and tested the 3 leads coming from the stator and no jump either. (This is where I can find an answer on the forum to what causes this).

    My buddy had a cover and stator/coil set up (off an '80 xs400) and swapped it and gave me the same reading above.

    Can the above be caused by a bad rotor, whats the best method to test that?
    What else should I test?
  2. CaptChrome

    CaptChrome XS400 Addict Top Contributor

    1. Measure the voltage across the battery terminals with the bike not running.
    2. Start the bike.
    3. Measure voltage across the battery terminals again while the bike is running and while revving it, if you do not have voltage above the battery voltage in step one, then your regulator is not working, is not hooked up correctly or is the wrong type.

    Make sure your regulator is designed to work with a field coil alternator and not a permanent magnet alternator.
    BBS360 likes this.
  3. tstidham

    tstidham XS400 Addict

  4. BBS360

    BBS360 XS400 Guru Top Contributor

    Like Chrome said, need to make sure you have the right kind of regulator for this bike.
    Which specific unit did you buy from rick's?

    Even if it claims to be compatible the problem with these aftermarket regulators is the bikes changed regulator style in the middle of the model run, but none of the aftermarket regulator manufacturers specify which type theirs are compatible with.

    I have seen far more issues posted about combination regulator rectifiers then I ever have seen success stories.
  5. CaptChrome

    CaptChrome XS400 Addict Top Contributor

  6. cezzz

    cezzz XS400 Member

  7. CaptChrome

    CaptChrome XS400 Addict Top Contributor

    I don't know anything about this unit and don't know anyone who has one, but it sounds like the Rick's Reg/Rec is not working, or it is hooked up incorrectly. The website is not really all that informative about the details of the unit or how it interfaces with the electrical harness due to its "different pin out", so hopefully whatever they sent as installation instructions give you some real details.

    Have you called them for some customer service and guidance? Calling them would be my next step. It also appears that there is a warranty for the unit, if you suspect it is bad.
  8. tstidham

    tstidham XS400 Addict

    Have you tried full fielding the alternator manually to see if the output rises? Since it is a ground regulation system, take the field wire to the regulator and jump it to ground briefly and see what kind of voltage you get. On my 78, I would see between 16 and 18 volts and sometimes close to twenty when I revved it to 5k rpms.
    CaptChrome likes this.

Share This Page