1. Dismiss Notice
  2. Dismiss Notice
  3. Hey Facebook people... We've created a group for XS400.com members to connect. Check it out!
    Dismiss Notice
  4. Want an XS400.com t-shirt? Go to the store to order. Limited sizes and quantities available.
    Dismiss Notice

Charging system.. again

Discussion in 'The Garage' started by a1steaksauce, Jul 7, 2019.

  1. a1steaksauce

    a1steaksauce XS400 Member

    So I have bought a new regulator and new rectifier.

    REGULATOR-
    I tried the tests for 12v on the regulator wires (brown green and indirectly black) and those were good
    but the resistance between the brown and green wires were 500ohms on my new one and about 1,200ohms on my old one. (the manual test says that it should be around 140ohms +/- 10ohms)
    Furthermore, when I did the test of attaching the green wire from the stator to the battery positive directly, the battery started charging really well (13v-14.5+volts)

    STATOR-
    The stator reads 1.5ohms across the 3 white wires but when accounting for the charge on the leads of the multimeter (.7/.8), the stator wires seem to be testing at .7/.8 which is exactly what I want

    FIELD COIL-
    The magnetism is present once I attach the green wire to the battery positive directly. Thus I think this is also good

    BATTERY-
    my battery is currently at 12.8V and therefore that could be bad but I imagine that it should still charge regardless.


    Did I just get another faulty regulator? and do I just need to buy another one?
    Is there any other part that could be bad? Could it be bad wiring?

    I know this is yet another charging system question that has been answered a billion times. I've read all of the threads on this matter but I would like to know if anyone has any experience on this and if the 140ohm test on the green and brown wires of the regulator is the right test.

    I've considered buying the r292 regulator but it seems like people have mixed reviews on this.

    My bike is a 80/81 SOHC by the way
     
  2. BBS360

    BBS360 XS400 Guru Top Contributor

    The 140 ohm test does not apply to your year of bike with its electronic regulator.
    Maybe I missed a previous thread but you haven't said what your symptoms are.
    Does the field coil magnetize when the regulator is installed? Not at all?
    Field coil should measure 4.04ohms.
     
  3. a1steaksauce

    a1steaksauce XS400 Member

    essentially my bike wont charge and it stays at around 12.4-12.5V the entire time.

    The field coil also did measure out to be 4.1ish ohms.
    I haven't checked whether the field coil magnetizes with the regulator installed but I will do that tomorrow and report back.

    I also don't think that my bike has an electronic regulator, or at the very least I have been buying the wrong regulators(1977-1980)
    The model is a (serial number) 4R4 (so either a 400SH or 400SJ or something like that)

    is there any way to check the "goodness" of a regulator beyond the tests I've already done?
     
  4. a1steaksauce

    a1steaksauce XS400 Member

    also as a quick question, does the regulator need to be grounded to the frame? is the black ground wire not enough?
    I haven't done this yet and maybe that could be a solution
     
  5. a1steaksauce

    a1steaksauce XS400 Member

    also my new regulator is from a 1979 model (I just found out that post1978 models have an electronic regulator)
     
  6. BBS360

    BBS360 XS400 Guru Top Contributor

    Attached is the Haynes test procedure for electronic regulators.

    It shouldn't need to be grounded to the frame.
     

    Attached Files:

  7. a1steaksauce

    a1steaksauce XS400 Member

    Also just to make sure again. Is the black wire from the stator supposed to connect to the brown wire from the voltage regulator as shown in the diagram? My friend and i discussed this and felt as though someone who has already worked on these would know best. This xs is a sorta ratty bike so we want to make sure the previous owner didnt screw up the wiring

    Also i plan on posting a list of step by step instructions with pictures for the charging system stuff that ive compiled and made a list for. Hopefully i'll be the last one to ask
     

    Attached Files:

  8. BBS360

    BBS360 XS400 Guru Top Contributor

    The stator only has white wires.
    The black field coil wire in your picture and the regulator brown both should connect to the brown supply wire in the wiring harness.

    On the earlier bikes with non-electronic regulators the black wire used to go to ground. Electronic regulators it goes to brown.
     

Share This Page