1. Having trouble logging in? Try closing your browser and re-opening it. If that doesn't work, try a different browser or device. The site will be updated soon to resolve these browser issues.
    Dismiss Notice
  2. Dismiss Notice
  3. Hey Facebook people... We've created a group for XS400.com members to connect. Check it out!
    Dismiss Notice
  4. Want an XS400.com t-shirt? Go to the store to order. Limited sizes and quantities available.
    Dismiss Notice

Front disk brake dragging!

Discussion in 'The Garage' started by Excess Impulse, Jun 17, 2017.

  1. Excess Impulse

    Excess Impulse XS400 Addict

    0730171300a.jpg Thought I should post an update to my brake problem as I have resolved it. I apologize for taking so long but must admit Im a little embarrassed as the issue was not the new brake line, new caliper piston and seal, nor was it the master cylinder. It was me, and an assembly error. I had put the little tension spring that holds the pads onto the pin in between the caliper and the inner brake pad, preventing the pad from moving away from the disk. Once I noticed this it was a 30 second fix and I am happy to say the brakes function good and I am finally on the road and enjoying the ride!
     
    BBS360 and xschris like this.
  2. Scorpio1963

    Scorpio1963 XS400 Guru Top Contributor

    Well simple enough I know my fix is going to cost $ some extra I dont have right now.Im trying to get the beater in top shape and some side work as popped up so Ive been rather busy.
     
  3. Jakwub

    Jakwub XS400 New Member

    Sorry to revive a 5 year old thread but I had this same issue on a '77 XS400D hat had been sitting for years.
    The solution for me was to take off the master cylinder, remove the screwed down & pressed on tank, and flush every hole I could find with brake cleaner. Jeff0133 was right in my case that the vent was clogged.

    For good measure I also went through the caliper, popped the piston out and cleaned everything thoroughly. To be clear though, the caliper cleaning was not the root issue since the front brake was still sticking before and after cleaning.
     

Share This Page