1. Having trouble logging in? Try closing your browser and re-opening it. If that doesn't work, try a different browser or device. The site will be updated soon to resolve these browser issues.
    Dismiss Notice
  2. Dismiss Notice
  3. Want an XS400.com t-shirt? Go to the store to order. Limited sizes and quantities available.
    Dismiss Notice

Cafe project finally running with Mike'S SX Carburetors

Discussion in 'The Garage' started by AndyJ, Jan 13, 2017.

  1. AndyJ

    AndyJ XS400 Member

    Hi,

    I've found this site and you all to be a wealth of knowledge in preparing this build.
    Started as an 81 Yamaha XS400 Special?
    This is its current state:


    Got it running pretty good with the Mike's SX Carburetors and stock exhaust.
    I've installed new spark plugs and confirmed correct ignition timing with a light.

    Quick questions:
    What would make the idle hang up high after revving, and at the same time it's popping and backfiring in occasion??
    My initial thought is that it's too lean..
    I haven't adjusted the valves yet.
    Any suggestions are greatly appreciated.

    Thanks!
    Andy
     
  2. OleDoc

    OleDoc FREEBIRDS MC Central NY

    check both the sync of the carbs or an carb intake leak
     
  3. xschris

    xschris XS400 Guru Top Contributor

    Adjust the valves first then sync. The few people that have tried these carbs had many issues. Even the xs650 guys don't like them.
     
    Last edited: Jan 14, 2017
  4. AndyJ

    AndyJ XS400 Member

    Thanks guys. After reading others experience with these I opted for the Banshee throttle set up. It works well, very crisp throttle response too :)
    I'm almost certain there's not any intake leaks.
    I have vacuum gauges to synchronize them and see if that helps..

    Thanks again!
     
  5. xschris

    xschris XS400 Guru Top Contributor

    I meant to say this.
     

Share This Page