1. Having trouble logging in? Try closing your browser and re-opening it. If that doesn't work, try a different browser or device. The site will be updated soon to resolve these browser issues.
    Dismiss Notice
  2. Dismiss Notice
  3. Want an XS400.com t-shirt? Go to the store to order. Limited sizes and quantities available.
    Dismiss Notice

No Spark on right side xs1979

Discussion in 'The Garage' started by tonyxs, Jul 23, 2023.

  1. tonyxs

    tonyxs XS400 Member

    11
    0
    1
    canada
    Hello Guys! I need some info on common problems that could prevent the right side of my bike from sparking.

    I had a electronic ignition that had issue on the right side, then switched back to points in effort to fix the issue, changed the coils , change the condenser, new rectifier regulator compatible with a new lithium battery (antigravity), changed the points plate, cleaned carbs and rebuilt head .. i don't know what part of the electrical would still cause this issue? i have an 1979 xs that used to run. its been stored for a while and it won't light up on the right side since last summer. I have a friend mechanic that helps me with it, but he's also out of clue.. Could it be just a bad static timing? I'd really love to get it running for the end of the summer.

    Thanks!
     
    Last edited: Jul 24, 2023
  2. CaptChrome

    CaptChrome XS400 Addict Top Contributor

    Here are a few things that weren't mentioned that you can try:
    Clean every wire contact between points and coils. Look for bad ground connection.
    Swap plugs side-to-side.
    Test the coils and swap them side-to-side.
    Install new plugs.
    Install new plug wires and caps.

    If you are checking for spark with the plugs out of the engine, then timing will not be an issue when just looking for spark. Trying to run the engine with bad timing is another issue though.
     

Share This Page