Air lock in fuel line?

gpounce32768

XS400 Enthusiast
Messages
84
Reaction score
38
Points
18
Location
Baltimore, MD USA
I've been shaking down the '82 XS today- took it out on the highway and pushed it hard, it rides pretty well but I got stranded twice on the high-speed runs (70mph) both times for 5 mins or so- apparently so the bowls could refill at which point the bike started right up.

I had put a transparent filter in which I <think> was keeping an air bubble in the fuel line causing the bowls to empty under the WOT. The symptom was sudden loss of power and stall, attempts to start on the side of the road which eventually succeeded- apparently after enough fuel trickled into the bowls.

When I made it home I pulled the carb end of the hose and let the hose drain back into the gas-can, I did see evidence of air-lock up around the filter- so am fairly confident that was the problem.

I replaced the filter assy with a simple hose, hoping that the air bubbles will have a chance to escape. I have some transparent fuel hose coming- I do want to be able to see the gas.

The petcock does flow well so I don't think the constriction is in there. So I <think> its handled but am wondering if there is any other experience out there with somewhat weird fuel flow issues.
 
The only fuel delivery related issues can be from (in order from the tank):
Petcock net filter in the tank is fouled with debris.
The petcock itself is blocked with internal buildup or not opening fully under vacuum.
Too small of a fuel line causing a restriction.
Too restrictive of an in-line filter.
The net filter below the carb bowl fill valve seat is clogged.
The carb bowl fill valve is not opening fully due to incorrect float level setting or leaking float.
 
It stranded me again the same way with a plain hose, so I don't think its air-related. But I have some transparent fuel line coming so I can see whats going on in there. I opened up the petcock, a bit of crud in there and the o-ring was tired so I have a mikesxs rebuild kit coming. Yeah I'm thinking at the moment that its old crud washed down into the fuel rail and is interfering with flow thru the float valves.
 
Got the carbs out today, nothing conclusive in the fuel rail- nice and open, no crud anywhere- compressed air didn't blow anything out and it flows fine. Any chance of the little conical screens over the float valve bodies constraining flow or somehow being naughty? I'm inclined to think not- brakekleen went thru with no problem.

The floats are empty and moving free, so would be floating fine and they'd both have to be jammed up to cause the bowls to empty. Level is set as per the external tube test in the service manual- its right on the money.

The symptom common to all 3 times I got stranded is after 5-10 mins or so the engine started right up and ran normally w/ its usual power but before then was acting like no fuel. I even had it happen sort-of a 4th time in front of the garage complete with an epic backfire. The first 2 times I was flogging the bike down the highway, 3rd time was idling waiting for a light, idling in front of the garage too..

Will put it all back together once I get the petcock rebuild from mike's. Kind of makes me wonder about something else perhaps heat related in the engine... next time it happens I'm going to test spark and check the plugs for wet/dry. Compression sounds fine as per the starter, it cranks like a full charge on the battery and the headlight is at its usual bright-ish luminosity.
 
Last edited:
So, what were the symptoms of the stranding? Like were you running at high speed and then the engine started loosing power over a period of time, or did it just quickly stop while at speed?

Looking at the plug color would be important here to help in the diagnosis. Getting a bike really heated up to temperature can sometimes induce rich or lean conditions that you might not see. I just had a lean condition where the bike started up normally and then went lean after slightly loose carb holder bolts heated up and expanded some allowing an air leak (and the bike did not want to restart without choke when hot). Look at the entire intake system, even outside of the carbs
 
The 1st two times were a rapid stall at near WOT like it ran out of gas. At the light I was just getting going after a green, but the same rapid stall. It wasn't a reduction in power as in running out of gas and needing to switch to reserve- the engine just rapidly and totally cut out. During restart attempts on the roadside, enrichener and petcock prime made no difference though I don't think I can exclude flooding as a cause- seems a stretch but it would make more sense than carb bowls running empty. Perhaps that might suggest the float valves NOT closing for some reason; that stuff is all new from a carb rebuild kit.

Yeah I like the weird rich/lean thing. The boots and all are snug but I know what you mean about vacuum leaks- I had that dance on my old Bandit for a while. Given the unclogged fuel line I'm definitely going to look into the plugs/spark etc next time it happens.
 
I don't feel like that is fuel. When I've forgotten to turn my petcock on, I can go a few blocks before she starts acting up and starting to bog and get jerky. Straight cutting out is usually a loss of spark as capt chrome is alluding too. Also, it would be unlikely both carb bowels would empty at exactly the same time.
 
Agreed. Going out with tools next time to check spark and sparkplug next time it quits.. oh well this is an excuse to get the emulsion tubes out of the carbs anyhow, I cheaped out and didn't pull them 1st time lol
 
Put on a transparent fuel line and brought a spark tester with me on a ride, got it die on me again. Definitely not fuel, the petcock flows fine. It takes about 10-15mins ride with moderate throttle eg 20 to 45mpg roads. The 1st warning was an odd pop, then about 15secs later it died on me in the usual way; no gradual sucking just a stall and dead. I put the spark tester on, got no spark- it doesn't fit great but I'm 80% sure it would have shown a spark- will have to test it later tonight when I have a chance.

Voltmeter showed battery at 15v peak, 13.5 or higher at normal rpm's- no signs of overvoltage. The regulator was not blazing hot, nor was the ignition module.

But after sitting by the side of the road for 10mins or so it started up nice and easy and I rode home. So I'm thinking ignition module... going to pull it, perhaps see if I can get a salvage replacement and try that?
 
lol now I see the TID12-07 scarcity for the Seca... yeah thats super-fun, so will dig into the unit and see if its sick and if so, repairable. I have it off the bike and the lid is off, going to test the pickup coil before desoldering the board... just like working on an old stereo lolz
 
I opened up the TID12 and took out the board. I sure love the old-school Hitachi construction- good stuff in there. No sign of solder fatigue or cold joints under the binocular scope or leaky caps/burned parts on the inside. The pickup coils measured fine and looked good visually, so I don't have any strong leads. Kind of thinking that the way forward is part swaps for the TID and/or pickup coils but I'm kind of tired of spending real money on the bike... unless anyone has other ideas?
 
Went out again, got it to shut down on me- I'm getting good at it lol. Same behavior, a few weird pops then a stall after 10 mins or so of 30 to 50mph, stops and go's, hills and flats- so, after working the bike for a bit.

Before the ride I wired in a voltmeter, took off the side fairings and carried some freeze spray with me. Once it shut down and I pulled off I checked heat on the regulator- was normal just a bit hot but not burning. I took off the cover of the igniter- the board was more or less ambient temp. I sprayed the cold spray onto and past the board into the igniter box in several shots over the course of a minute or two; engine would not start. During the ride the voltmeter didn't show anything over maybe 15v max.

So I put away the stuff and briefly tried to start every 5 mins or so. After 15 mins or so it started up nice and easy, so I rode the couple miles home. The usual...

Given that cooling the igniter board made no difference I'm going to look into the coil pickup harness, perhaps its some kind of short that develops from the case expanding thru the heat of a harder ride. That doesn't exonerate the igniter from some other more obscure fault but the board sure looked pristine so I'm not thinking that is likely.
 
Might have found it.. I pulled off the timing cover, timing armature and coil plate. The two pickup coils are screwed down to the plate, with their respective harnesses leading off the edge, thru a rubber gland, from there up to the ignitor. There is a spring clip screwed to the coil plate to hold down the harnesses where they go thru the gland. I noticed the end of the spring was pressing on the grey pickup wire- hooked up my meter and found the insulation had been worn away by the spring end chafing it- literally no insulation left on that spot on the wire.

So the theory at the moment is if (when?) the spring flexed through the engine heat and touched the grey wire it eventually wore through the insulation and caused grey-wire pickup coil to short to ground. Next step is to set up stronger magnification to see if the conductor itself is damaged- unless its really bad I'm not going to tear up the wiring, or get in there with sealants or tape since this is inside the engine case. But I'll bend out that spring, maybe slide the woven tubing down around the harness tighter to the gland.
 
One of the things I did with my 78 when I got it was to plug and unplug every wire connector so as to knock any corrosion off and clean the circuit so to speak. It also let me feel for any loose ones. I only had two bullet styles that just needed a little tweak with some needle nose to tighten them up. Same for the glass fuses. Prior to that, I had a few circuits that were dropping about a half volt or so. That definitely cured those low volt readings too. Thanks for keeping us updated on your trouble shooting!
 
:) yeah I know all about intermittent/dirty connectors- went over all of them when I had the regulator and ignitor off- I was in the fuse box at the start of the job. All that stuff was in good condition thankfully- the bike only has 2500 miles on. I keep getting the vibe the original owners were having problems with it, so it stayed parked for decades but at least not out in the weather.

Anyhow, as for the pickup harness wire- the insulation was split open but wire inside is intact. The clip isn't actually a spring, just a stamped piece with a finger projecting out over where the wires pass thru the gland- so easy to bend that up slightly. Bike started fine after I put it back together, will test again tomorrow.

Working thru this stuff is fun when making progress.. the XS is a nice little bike all told- it sure is simple and easy to work on. I bet the bigger XS's are a blast.
 
I dipped back into debugging my Seca. Over the summer I picked up a 2 channel portable oscilloscope and realized I could hook it to the timing coils in an attempt to see if the engine stall is due to a problem there or in the ecu. So I did that, took a little longer for the engine to die but I was all ready when it did. When trying to start the engine I found one timing coil produced no signal and the other one was very low. With the engine cool, both signals were easily 10v peak-to-peak. On the side of the road one produced no signal the other was maybe 4v peak to peak.

So I pushed the bike into the shade and wasted time on my phone for a while. Then with the scope on I tried starting the bike- both coils back to normal and the bike started fine, I rode home and checked again before I shut off- both coils still producing good signal.

So I <think> this means there is a signal generation problem with the timing coils. Both measure fine resistance-wise, so I;m wondering abut the timing armature. Perhaps as it gets hot it flexes away from the coils and the coupling is lost, so eventually the ecu loses the timing signal.

So back into the timing cover I guess... Earlier I removed the cheesium JIS head screws and replaced with stainless socket button-head screws which are lots easier to set up- definitely recommended if you have occasion to open up the engine.
 
Good stuff! I had a short-term dropout of one cylinder after a long ride during a very hot summer day. I haven't had it since, but I am very interested what you find out as you troubleshoot this issue. I am gathering that the oscilloscope is going to be a really key diagnostic device for this. Keep us posted!
 
I've been working with a friend of mine who wants to try riding so set up the XS for her- she did fine, got going around the parking lot no sweat. Happily it was running long enough for the ignition fault to occur again, and I had my scope handy. It showed the usual disappearance of one of the trigger coil signals. A resistance check showed that coil gone nearly open (approx 3 megaohms) instead of the usual 120-150ohms. I kept the meter running while the engine cooled, the resistance slowly dropped over the course of 5-10 minutes or so down to 2.5 megaohms until it suddenly dropped back to the normal approx 120ohms and the engine ran fine.

I think this exonerates the ECU as the cause, perhaps indicating some kind of thermal effect affecting a cracked wire or joint. So the next move is to pull the ignition trigger coil assembly and harness to investigate the wiring.
 
Got the trigger coil assembly off the bike and on the bench. I hooked the ohmmeter on grey and orange- putting the coils in series. Then I got out the heat gun and started warming the pair of trigger coils, after a few minutes with both a bit too hot to touch the grey wire coil went open and the orange wire coil stayed OK; so theres my culprit; temperature related failure of the grey wire trigger coil.

I bought a ebay set of XJ550 trigger coils- apparently all coils except for those for the XS400 are cheap lol. The XJ's coils are 600 ohms each vs approx 120 for the XS's so I'm going to look into adapting the XJ coils which will fit the 400's trigger plate. Perhaps a parallel resistor to bring down the total impedance but I need to do some testing with signal levels and so on.
 
Last edited:
Back
Top